As of Tuesday, April 11, 2017, Microsoft will no longer support desktop operating systems that are not compatible with Transport Layer Security (TLS) 1.2. Because of this, our Business Online Banking and FirstLink Online Banking users will need to verify that their current operating system (OS) or browsers support TLS 1.2. To ensure you do not experience unnecessary service interruptions, please upgrade your OS version or browsers to be able to connect using TLS 1.2, if necessary. Please note, if you do not have a compatible OS version or browser, you will receive a connection error when attempting to access the Business Online Banking or FirstLink Online Banking sites. If you have any questions, please do not hesitate to contact us.

Log In